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Bringing in fixed width data 
1. Open Excel 
2. Open the file Cash Flow Summary 
3. Make sure to split the columns 
4. Add a few rows on top 
5. Add a row on the side 
6. Add Total Column  
7. Add Total Row 
8. Title the data and worksheet 2017 Cash 

Flow 
9. Put in Totals 
10. Make the digits money 

 

 

 

 

You can add sparklines to the totals to see how the company is doing by Quarter or by Country: 

 

 You will have to create a new set 
of sparklines for quarters – but 
then you can copy all using autofill 
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Pivot Tables 
A PivotTable report is an interactive table that you can use to quickly summarize large amounts of data. 
You can rotate its rows and columns to see different summaries of the source data, filter the data by 
displaying different pages, or display the details for areas of interest You can start a Pivot table by 
opening the Pivot Table toolbar and clicking on the wizard. 

Open Sorting Lists.xls 

Independent Variable - a variable (often denoted by x) whose variation does not depend on that of 
another. 

Dependent Variable - a variable (often denoted by y) whose value depends on that of another. 

1. Click anywhere in the data 
2. Insert->Pivot Table 
3. Click OK 

 

 

Check the data, is it correct? What does this tell you? 

Perhaps we should re-arrange the data.  Instead of County and Month – try Type and month.  Do this 
just like playing solitaire – drag and drop the fields to the place you want. 
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Slicers 

Applying these kinds of filters to one or two PivotTables is not difficult or time consuming, but if you 
have to apply the same filter over and over again, the process becomes frustrating and inefficient. To 
combat this, Excel offers a PivotTable featurecalled the slicer. A slicer is very similar to a filter field, 
except that it is independent of any PivotTable. This means that you can 
apply the same slicer to multiple PivotTables.  

 

  

 

Grouping Data together 
Most PivotTables have just a few items in the row and column fields, which makes the PivotTable easy 
to read and analyze. However, it is not unusual to have row or column fields that consist of dozens of 
items, which makes the PivotTable much more unwieldy. To make a PivotTable with a large number of 
row or column items easier to work with, you can group the items together. For example, you could 
group months into quarters, thus reducing the number of items from 12 to 4. Similarly, a PivotTable that 
lists dozens of countries/regions could group those countries/regions by continent, thus reducing the 
number of items to four or five, depending on where the countries/regions are located. Finally, if you 
use a numeric field in the 
row or column area, you 
might have hundreds of 
items, one for each numeric 
value. You can improve the 
PivotTable by creating just a 
few numeric ranges. In Excel, 
you can group three types of data: numeric, date and time, and text.  
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Group Time by Pivot Table 
Using the transactions with time worksheet, we can see we have a table of sales data that contains one 
row for each transaction. The boss wants to see a report that shows how many transactions took place 
during each hour of the day. 

The quickest and easiest solution would be to use the Group feature in a Pivot Table.  This solution is 
also the most limiting because you will only be able to group the times in 1 hour increments. 

 

 

 

 

 

Reference data in PivotTable 
What do you do when you need to include a PivotTable result in a regular worksheet formula? At first, 
you might be tempted just to include a reference to the appropriate cell in the PivotTable’s data area. 
However, that works only if your PivotTable is static and never changes. In the vast majority of cases, the 
reference won’t remain accurate because the addresses of the PivotTable values change as you pivot, 
filter, group, and refresh the PivotTable. 

Let’s use the trees pivot table.  We want to find the number of trees purchased by a county during a 
month. 

 

 

We can set up our equation so that we can put in different values and it 
will then give us the solution: 

 

 

Right-click and group by hours 
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The equation in H3 would be: 

=GETPIVOTDATA("Quantity",$A$6,"Months",H2,"County",H1) 

In this case, we would get 66500 trees. 

If we changed the county to cook – then we get 0. 

Add Calculated fields 
By default, Excel uses a Sum function for calculating the data field summaries. Although Sum is the most 
common summary function used in PivotTables, it’s not the only one. 

But what if we wanted a field based on a formula?  For example, we may get a commission of $.05 off 
every tree we sell. 

The equation would be: =Quantity * 0.05 

 

And then changing the format to Currency: 
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Format Data 
This is under the design tab.  You can do lots of configurations with this – Totals, Subtotals, etc. 

Here is an example of the pivot table with an additional type added to the Rows, and adding a Blank row 
using the blank Rows button. 
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Pie Charts 
These charts represent the parts of a whole. Each ‘section’ or ‘slice of the pie is a data percentage. From 
biggest to smallest, segments are arranged in a clockwise formation. This way, the pie chart features 
easy-to-compare subjects presented in a neat, easy-to-understand way. 

Create your own Pie Chart 
1.) Open the tab timesheet. 
2.) Select the names in column B 
3.) Using  your CTRL key, select the gross pay in column E 
4.) To insert the graph, select insert pie, 2D 

Again, not too hard.  But, I don’t like the color scheme.  You can change that using the Gallery’s selection 
on the top of the page.   

Also, let’s put the series 
name over the top of the 
pie pieces to make it 
easier to read along with 
their percentages. 

OK, again I would call this 
the minimum acceptable 
chart.  Perhaps we should 
draw our eyes to Smith 
since he is getting paid so 
much more than the rest 
of us.  To do this: 

1.) Click once on Smith’s pie piece.  They are now all selected 
2.) Click again on Smith’s pie piece.  Now only Smith is selected. 
3.) Drag Smith’s pie piece out 
4.) Re-color the pie piece to hot pink. 

  

Fredrickson
19%

Jones
18%

Monroe
20%

Peterson
19%

Smith
24%

Chart Title
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Bar Graphs 
The bars’ heights are scaled according to their values and the bars can be compared to 
each other. Bar graphs can be drawn in a 3-dimensional way and compiled for data 
comparison about the same thing or location. So that more important categories are 
emphasized, bars in a bar graphs are arranged in order of frequency. 
Create your own Bar Graph 

In this first exercise, we would like to see the magnitude of sales by date.   

1.) Open the tab called More Data 
2.) Select from A2:D6 
3.) Go to Insert->Insert Column Chart->2D Clustered Column 

Boom! We have a chart.  That was easy…  But, my instructors always 
said a chart without a title is a graph.  Add a chart title by selecting the 
Chart Layout with a Title on Top.  Name the chart “Employee Sales by 
Month”  

Now, it may be obvious what the y-axis is (money), but perhaps we 
should label it and use currency. 

1.) Select the data that makes up the graph 
2.) Go to the Home tab 
3.) Select the $ for money 

To add a title on the axis: 

1.) Select the Chart 
2.) Select Layout under the Chart 
3.) Select on Axis Titles 
4.) Select Vertical 
5.) Put in “Sales” 

Now, this graph is minimal – meaning the minimal we can get away with.  Let’s make it better.  Let’s 
annotate why Peterson’s numbers are so low, “He’s rarely here” 

1.) Select the text box under insert 
2.) Draw out a box to put text 
3.) Put in the text, “He’s Rarely Here” 
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Line Graphs 
Line Graphs are great for showing trends in data.  Is the item you are looking at going up or down?  Is it 
staying consistent? 

Let’s show the stock prices of Apple and Microsoft from Jan 1, 2000 to Jan 1, 2015 (weekly) against the 
Dow Jones Industrial Average 

Open the tab Stocks. 

Wow!  That’s a lot of data.  Let’s hide everything except the closing data for all 
items. 

1.) Select the column that we want to hide (e.g. column B) 
2.) Right click on the selection giving you a context sensitive menu 
3.) Select hide 

Voilia!  Repeat until it looks like this: 

Now, to graph, select the date and the Apple close.  We will add Microsoft close 
later in the exercise.  Use the CTRL+Shift+Down Arrow to grab everything 
quickly! 

While selected, Insert->Graph->Line 2-D 

Wow!  That was easy! Let’s add Microsoft. 

1.) Select the chart 
2.) Go to Chart Tools->Design-> And in the data section, 

choose Select Data. 
3.) Click the Add button on the Legend Entries 
4.) Type Microsoft into the Series name and select the series values 

 

 

 

 

 

 

 

 

  



 

  Page 11 of 18 

Pareto Graph 
Many people have heard of this as the “80-20 rule”. That is, that doing 20% of the work can generate 
80% of the advantage of doing the entire job. In the idea of quality improvement, we can say that a 
large majority of the problems (80%) are produced by a few key issues (20%). 
 
Open the File Pareto 
 
1.) Sort rows in decreasing order of importance of the causes (i.e., the most important cause first) 
2.) Sum the numbers together 
 
Add a cumulative percentage column to the table 
Add a new column to the table and get the percentages of each of the complaints. This is done 
by taking the quantity of each complaint, dividing it by the total number of complaints, and 
multiplying by 100. 
For example, hospital cafeteria food (bad) has 159 complaints. So 159/557*100 = 28.5% 
 
 

 

 

 

 

 

 

 

 

 

4.) Plot with numbers on the left and cumulative percentages on the secondary y axis. 
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Save a chart as a template  
After you’ve changed a chart’s type and performed other chart-related chores such as applying titles, adding 
labels, and choosing a layout, you might want to repeat the same settings for another chart. Rather than repeating 
the procedure to create the second chart, you can make your life easier by saving the original chart as a chart 
template and then creating the second chart (and any subsequent charts) based on this template. By default, chart 
templates are stored in the C:\Users\user name\AppData\Roaming \Microsoft\Templates\Charts folder.  

To save a chart as a template  

1. Right-click the chart’s plot area or background, and then click Save as Template.  
2. Enter a name for the template, and then click Save.  
 

To create a new chart based on a template  

1. Select the range of data you want to chart.  
2. On the Insert tab, in the Charts group, click Recommended Charts.  
3. Click the All Charts tab, and then click Templates.  
4. Click the template you want to use, and then click OK.  
 

To apply a template to a selected chart  

1. In the Change Chart Type dialog box, on the All Charts tab, click Templates.  
2. Click the template you want to use, and then click OK. 
 

 

Scatterplot 
Scatterplots display paired data using the vertical or the y axis and a 
horizontal axis or the x axis. The tools for statistics called correlation and 
regression are then used for showing trends on this type of graph.  

Create your own Scatterplot 
Open the file scatterplot 

1. Select the data from C4:D15 
2. Go to Insert->Scatter-> 2D plot 
3. Add Titles and Labels 
4. Profit! 

Make sure the x-axis values are on the right of the table.  This is default in Excel. 
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An awesome feature in excel is to get the trendline! 

1. Select the chart 
2. Select Chart Tools->Layout->Trendline 
3. You, as the expert, will have to say what type of trendline the data is representing. 
4. I also recommend getting the equation on the chart 
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Maps 
When using Powermap, we have to be very precise in location.  The best way for getting precise 
geographic data is Longitude and Latitude.  But, that won’t work when we are talking about counties!  
So, we have to be precise in the counties we are talking about.  Did you know there are St. Louis 
counties in MN and MI?  Or Lake counties in MN, IN, IL?  So, states are important! 

1. Select the data from A1:G9.  Notice that the headers of the data were selected. 
2. Click Insert->Map->Launch Power Map 
3. A new Panel will open saying “Launch Powermap” and at the bottom, there will be a + sign with 

the label “New Tour” 
4. Click “New Tour” 
5. A new window opens with the world on it.  On the right, a panel shows up 

that has the headings of our data.   
6. Select County 

Items appear on the map with County in the Geography and 
Map Level 

7. Click Next 
8. Now that the counties are selected, it is time to select the 

dependent variable to graph.  Select Per Cap 2007. 
We now have columns of the money on each county.  This is great – but not 
very useful. 

9. Above Height on the right, there are different ways to look at the data 

 
a. Stacked Column 
b. Clustered Column 
c. Bubble Graph 
d. Heat Map 
e. Visualization by Region—select this 

10. Now, each of the counties are colored.  They do differ 
slightly between them, but we may need to increase the 
amount of contrast.  Select the Cog on the top of the panel 
for Layer Options. 

11. This formatting allows for changes in color and contrast.  
Change the Color Scale to 25% and zoom in 
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15 Excel Tips and Tricks 

1. CTRL+Y  -- Redo 
‘Nuff Said 
 
 

2. Multiple Cells, Same Data 
 
For some reason, you may have to write the same thing over and over again in cells in a 
worksheet. That's excruciating. Just click the entire set of cells, either by dragging your cursor, or 
by holding the Ctrl key as you click each one. Type it on the last cell, then hit Ctrl+Enter—and 
what you typed goes into each cell selected. 
 

3. Paste Special with Formulas 
 
Let's say you've got a huge amount of numbers in decimal format you want to show as 
percentages. The problem is, that numeral 1 shouldn't be 100%, but that's what Excel gives you 
if you just click the Percent Style button (or hit Ctrl-Shift-%). You want that 1 to be 1%. So you 
have to divide it by 100. That's where Paste Special comes in. 
 
First, type 100 in a cell and copy it. Then, select all the numbers you want reformatted, select 
Paste Special, click the "Divide" radio button, and boom goes the dynamite: you've got numbers 
converted to percentages. This also works to instantly add, subtract, or multiply numbers, 
obviously. 
 

4. Transpose Data from a Row to a Column 
 
You would use this feature if you want to transpose data to get a better display; however, 
retyping all data would be the last thing you would need to do if you know how to use the 
Transpose function in Paste. Here’s how: copy the area you want to transpose, move the pointer 
to another blank location. Go to Home->Paste->Transpose, please note that this function won’t 
activate until you copy the data first. 
 
 

5. Save Charts as Templates 
 
Excel has more types of charts than Jimmy Carter's got teeth and peanuts, but it's almost 
impossible to find a default chart that is perfect for your presentation. Thankfully, Excel's ability 
to customize all those graphs is exemplary. But when you have to recreate one? That's a pain. It 
doesn't have to be. Save your original chart as a template. 
 
Once a chart is perfected, right-click on it. Select Save as Template. Save a file with a CRTX 
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extension in your default Microsoft Excel Templates folder. Once you do that, applying the 
template is cake. Select the data you want to chart, go to the Insert tab, click Recommended 
Charts, and then the All Charts tab, and the Templates folder. In the My Templates box, pick the 
one to apply, then click OK. 
 
Some elements, like the actual text in the legends and titles, won't translate unless they're part 
of the data selected. You will get all the font and color selections, embedded graphics, even the 
series options (like a drop shadow or glow around a chart element). 
 

6. Work With Cells Across Sheets 
 
This one, called 3D Sum, works when you have multiple sheets in a workbook that all have the 
same basic layout, say quarterly or yearly statements. For example, in cell B3, you always have 
the dollar amount for the same corresponding week over time. 
 
On a new worksheet in the workbook, go to a cell and type a formula like =sum('Y1:Y10'!B3). 
That indicates a SUM formula (adding things up) for all the sheets that are titled Y1 to Y10 (so 10 
years' worth), and looking at cell B3 in each. The result will be the sum of all 10 years. It's a good 
way to make a master spreadsheet that refers back to ever-changing data. 
 

7. Hide in Plain Sight 
 
It's easy to hide a row or column—just select the whole thing by clicking the letter or number 
header, right-click, and select "Hide." (You can unhide by selecting the columns to either side all 
at once, right-clicking, and selecting "Unhide"). But what if you have just a little section of 
inconveniently placed data you want to hide, but you still want to be able to work with? Easy. 
Highlight the cells, right-click, and choose Format Cells. On the Number tab at the top, go to 
Category and select "Custom." Type three semicolons (;;;) in the Type: field. Click OK. Now the 
numbers aren't visible, but you can still use them in formulas. 
 

8. Speed up Inputting Complicated Terms with AutoCorrect 
 
If you need to repeat the same value and it is complicated to input, the best way is to use the 
AutoCorrect function, which will replace your text with the correct text. 
 

9. Status Bar 
 
The status bar is always there but we hardly use it to the full. If you right click on it you can see 
there hell lot of things which you can check using status bar. 
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10. Highlight Blank Cells 

 
When you work with large data sheets it’s hard to identify the blank cells from it. So the best 
way is to highlight them by applying a cell color. 
 
Here are the steps to do this. 
 

 First of all, select all the data from the worksheet 

 After that, go to Home Tab ➜ Editing ➜ Find & Select ➜ Go To Special. 
 click goto special 
 From Go To Special dialog box, select Blank and click OK. 
 At this point, you have all the blank cell selected and now apply a cell color using font 

settings. 
 
 

11. Root of Number 
To calculate square root, cube root or any root of a number the best way is to use exponent 
formula.  In exponent formula, you can specify the Nth number for which you want to calculate 
the root. 
 
=number^(1/n) 
 
For example, if you want to calculate a square root of 625 then the formula will be: 
 
=625^(1/2) 

 

 


