Excel Expert
Session 2 — Customizing Everything

Instructor: Don Bremer



Change Tabs

Under Options, there is a way to customize the ribbon. This includes adding and hiding tabs.

Excel Options ? X
G | .
enee I:{‘EI.J Customize the Ribbon.
Formulas
Choose commands from: (@ Custemize the Ribbon: (0
Dat:
o | Popular Commands '| | Main Tabs i
Proofing
Save .Y Add or Remove Filters E Main Tabs
oLl All Chart Types... Background Removal
Language +i Borders 3 B [+]Home

Ease of Access

Advanced

‘Customize Ribbon

Quick Access Toolbar
Add-ins

Trust Center

Calculate Now

Center

d Conditicnal Formatting

| Copy

Customn Sort...

Cut

Decrease Font Size

Delete Cells...

Delete Sheet Columns

Delete Sheet Rows

Emnail

Fill Color

Font

Font Color

Font Size

Format Cells

& Format Painter

Freeze Panes

Increase Font Size
Insert Cells...

fi Insert Function...

3 Insert Picture

Insert Sheet Columns

Insert Sheet Rows

Insert Table

Macros

Merge & Center

EVRd eV

Clipboard
Font
Alignment
Number
Styles
Cells
Editing
Ideas

Insert

[ Draw

Page Layout

Formulas

Data

Review

[ View

[J Developer

[ Add-ins
Help
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| Mew Tab | ‘ New Group | | Rename... ‘

Customizations: "i)

Import/Export ¥ |

Manage Workbook Versions

If you want to go “Back in Time” to
another version, or if the computer died
without saving your changes — the
computer does that for you. This is found
when you open the workbook and go to

Version
History

File->Info

Version History

View and restore previous versions,

Manage Workbook

'raj There are no unsaved changes,

[y Recover Unsaved Workbooks
Elé? Browse recent unsaved files

tions

en this workbook

Delete All Unsaved Workbooks
E < Delete all recent copies of

unsaved files

Page 2 of 11



Configure Auto Recover

General

Data

Proofing

Add-ins

Formulas

Excel Options

Language

Ease of Access
Advanced
Customize Ribbon

Quick Access Toolbar

Trust Center

Customize how workbooks are saved.

Save workbooks

AutoSave OneDrive and SharePoint Online files by default on Excel G

Save files in this format: Excel Workbook (*.xlsx)

Save AutoRecover information every | 10 5| minutes
Keep the last AutoRecovered version if | close without saving

AutoRecover file location:

[] Don't show the Backstage when opening or saving files with keyboard shortcuts

Show additional places for saving, even if sign-in may be required.
[] Save to Computer by default

Default local file location: Ch\Users\Mikaela'\Documents

Default personal templates location:  |C\Users\Mikaela\Documents' Custom Office Templates

[ Show data loss warning when editing comma delimited files (*.csv)

AutoRecover exceptions for: ﬂ ExcelExpert_2-1xlsx  ~

[] Disable AutoRecover for this workbook only

ChUsers\Mikaela\ AppData\Roaming\Microsoft\Excel\

And While we are here... the test really wants you to know how to set the calculations to manual.

General
Formulas
Data
Proofing
Save

Language

Ease of Access

Advanced

Customize Ribbon

Change options related to formula calculation, performance, and error handling.

Calculation options

Workbook Calculation®d Enable iterative calculation

() i 5 %
Automatic Maximum lterations:

utomatic except for data tables Maximum Change:

Working W

R1C1 rafaranca chilall

To manually recalculate formulas in only the active worksheet

On the Formulas tab, click Calculate Sheet.
Press Shift+F9.

To manually recalculate formulas in every open worksheet

On the Formulas tab, in the Calculation group, click Calculate Now.

Press F9.

To manually recalculate every formula in every open worksheet

® Press Ctrl+Alt+Shift+F9.

100
0.001

-~
-
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Custom Formats

Excel custom number formats have a specific structure. Each number format can have up to four
sections, separated with semi-colons as follows:

[Blue]i#,##0.00_) ; [Red](#,##0.00) ; 0.00 ; “sales "@

This structure can make custom number formats look overwhelmingly complex. To read a custom
number format, learn to spot the semi-colons and mentally parse the code into these sections:

e Positive values
o Negative values
e Zero values

e Text values

Symbol Description

# Holds a place for a digit and displays the digit exactly as typed. Displays nothing if no
number is entered. For example, if a cell’s custom format is ### and you enter 25 into
the cell, Excel displays 25

0 Holds a place for a digit and displays the digit exactly as typed. Displays zero if no
number is entered. For example, if a cell’s cus
? Holds a place for a digit and displays the digit exactly as typed. Displays a space if no

number is entered. For example, if a cell’s custom format is 0??? and you enter 25
into the cell, Excel displays 0 25.

. (period) Sets the location of the decimal point. For example, if a cell’s custom format is #.#0
and you enter 34.5 into the cell, Excel displays 34.50.
, (comma) Sets the location of the thousands separator. Marks only the location of the first

thousand. For example, if a cell’s custom format is #,### and you enter 12345 into the
cell, Excel displays 12,345.

% Multiplies the number by 100 (for display only) and adds the percent (%) character.
For example, if a cell’s custom format is #% and you enter .75 into the cell, Excel
displays 75%.

“text” Inserts the text that appears within the quotation marks. For example, if a cell’s
custom format is “Part “\#00-0000 and you enter 123456 into the cell, Excel displays
Part #12-3456.

@ Displays the cell’s text. For example, if a cell’s custom format is @” entry” and you
enter credit into the cell, Excel displays credit entry.
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[color] Displays the cell contents in the specified color. For example, if the cell’s custom
format is 0.00[green];0.00[red], Excel displays positive cell values in green and
negative cell values in red. The predefined color values you can use are black, white,
red, green, blue, yellow, magenta, and cyan, and the color codes color8 through
color55.

Open the Workbook Excel Expert — Session 2 -> Custom Data Formatting

Open the customization window:

File Home Insert Page Layout Formulas Data Review View Help
|:| d Cut Calibri “ 14 LA === L EE}Wrap Text General - @
(A Copy ~
Paste = = = = 3= 5 000 Condi
I U ~ M A~ = === 5= - v O &
_ < Format Painter u -y === =3= Merge & Center $ % 9 <58

Formal

Clipboard 5 Font (= Alignment & Mumber @

Format Cells 7 >
Examples: Mumber Alignment  Font  Border Fill Protection
SS Category:
General Sample
Phone Mumber 1234
Currency
Accountin .
Menards SKU ate e Lype:
Time 0
Percentage General ]
Fraction
Scientific 0.00
Text # #£])

Special #££0.00

(Costom I P g

# ##0.00_); [#,#£0.00)

= #20,00_:[Red](=,#20.00)

& 20 (5= 220

S #2£0 ):[Red](5%,220)

S# ££0,00 ):(5%,££0,00) h

Delete

Type the number format code, using one of the existing codes as a starting point.

When using time, we can use an entirely new set of tools!
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To display

Months as 1-12

Months as 01-12

Months as Jan-Dec

Months as January—December
Months as the first letter of the month
Days as 1-31

Days as 01-31

Days as Sun-Sat

Days as Sunday-Saturday
Years as 00-99

Years as 1900-9999

To display

Hours as 0-23

Hours as 00-23

Minutes as 0-59

Minutes as 00-59

Seconds as 0-59

Seconds as 00-59

Hours as 4 AM

Time as 4:36 PM

Time as 4:36:03 P

Elapsed time in hours; for example, 25.02
Elapsed time in minutes; for example, 63:46
Elapsed time in seconds

Fractions of a second

Use this code
m

mm

mmm
mmmm

mmmmm

dd
ddd
dddd

yy
yyyy

Use this code
h

hh

m

mm

s

Ss

h AM/PM
h:mm AM/PM
h:mm:ss A/P
[h]:mm
[mm]:ss

[ss]

h:mm:ss.00
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Fill Series
Go to the Fill Series Tab.

For a linear series, it just goes up by +{step}

A C D E
1 |Linear Growth Date(Day) Date (Weekday) Date (Month)
2 | 0_| 1 1/1/2017 1/1/2017 1/1/2017
3 5
4| 10
5 i 15 Series ? x
& | 20 Series in Type Date unit
7 i 23 O Eows @ Linear Day
a il 30 @ LColumns O Growth ‘Weekday
9 35 (O Date Month
10 40 (O AutoFill Year
11 45
12_ 50 |:| Trend
13_ 55 Step value: |5 Stop value: 125-|
14 60
5| e Concel
16 | 70
For a Growth Series, it goes up by *{step}
A B C . D . E |
1 |Linear Growth Date(Day) Date (Weekday) Date (Month)
2 0 1 LJ": 217 11 fwn17 11 /w17
3 5 7_. Series ? >
4 | 10 4 Series in Type Date unit
3 | 15 8 D Linear Day
& | 20 16 @ Growth Weekday
T 25 32 O Date Maonth
8 30 64 ) AutoFill Year
9 | 35 128
10| 40 256 LR
11_ a5 212 Step value: |2 Stop value: | 4096
e R [ ox ]
1 Cancel
i3] i E— | oK |
14_ a0 4096
15_ 63

Then, we can also use that for days and weekdays:
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A B i D E F G

L= == e I = R L

Linear Growth Date(Day) Date (Weekday) Date (Month)

0 1 1/1/2017 1,.:"1,.:"201?1 1/1/2017

2 2 1/2/2017 Series ? =4
10 4 1/3/2017
15 8 1/4/2017 Series in Type Date unit
20 16 1/5/2017 (®) Rows () Linear () Day
25 32 1/6/2017 () Columns () Growth (®) Weekday
30 64 1/7/2017 (®) Date i) Manth
35 128 1/8/2017 O Autofill O Year
40 256 1/9/2017 [ rend
45 512  1/10/2017
50 1024 1;"11;"2{]1? Step value: |1 Stop value: 2.."1.."21}1?1
35 2048 1/12/2017 Cancel
60 4096 1/13/2017
65 1/14/2017
70 1/15/2017
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Data Validation

The best solution for preventing data entry errors is to use the data-validation feature of Excel.

e Select the range to which you want to apply rules

e Data -> Data Tools -> Data Validation

For example, let’s make sure a loan amortization only allows positive years and positive %!

B2 X F 6%
| 2 L R
1 |Loan Payment Analysis

|Interest Rate (Annual) | 6,00%_|

Periods (Years) 2
Principal $10,000
'Monthly Payment ($443.21)

Custom Conditional Formatting

Student Grades Tab

| Data Validation

Settings  Input Message
Show error alert after invalid data is entered

When user enters invalid data, show this error alert:
Style: Title:
Stop | |WTF
Error message:
They are paying you?

Cancel

Custom conditional formatting can help you answer the following:

e Which cell values are less than 0?
e What are the top 10 values?

o Which cell values are above average, and which are below average?

e Highlight cell rules
e Top/Bottom rules
e Data bars

e Color scales

e |con sets
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Create conditional formatting rules that use formulas

Excel comes with another conditional formatting component that makes this feature even more
powerful: you can apply conditional formatting based on the results of a formula. In particular, you can
set up a logical formula as the conditional formatting criterion. If that formula returns TRUE, Excel
applies the formatting to the cells; if the formula returns FALSE, instead, Excel doesn’t apply the
formatting.

Encrypt a workbook with a password

For a workbook with confidential data, merely protecting cells or sheets might not be enough. For a
higher level of security, you can encrypt the workbook with a password. This prevents anyone who
doesn’t know the password from opening the workbook.

To encrypt a workbook with a password
1. In the workbook you want to protect, display the Info page of the Backstage view.

2. Click Protect Workbook, and then click Encrypt with Password.

My Workbook - Excel

Info

Export

Publish

Close

Account

Options

Feedback

U Let readers know the workbook is final and
make it read-only.
Encrypt with Password

} Require a password to open this workbook.

| Protect Current Sheet
=i Control what types of changes people can
make to the current sheet.
1] Protect Workbook Structure

=g} Prevent unwanted changes to the structure
of the workbook, such as adding sheets.

D Restrict Access

@ Grant people access while removing their  *
ability to edit, copy, or print.

[L‘ Add a Digital Signature

Ensure the integrity of the werkbock by
adding an invisible digital signature.

My Workbook
Documents
Protect Workbook Properties ~
Control what types of changes Size
Protect people can make to this workbook.
Workbook ~ Title
Tags
Mark as Final
o Morkas Fina Categories

Related Dates
Last Modified
Created

Last Printed

Related People
Author
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Custom color/font schemes

If you want to have your spreadsheets to have a common look throughout your company, you can
create a custom color scheme.

Create New Theme Colors

Text/Background - Dark 1

Text/Background - Light 1

Text/Background - Dark 2
Text/Background - Light 2
Accent 1
Accent2

Accent 2

Accent 4
Accent 5
Accent &
Hyperlink

Eollowed Hyperlink

EEERERRRCEEE

Theme colors Sample

& B
I i

Text Text

Hyperiink
Hyperiink

Name: ‘Cuslom 1

Colors

Standard Custom

Colors:

Y

Color model: |RGBE

(<]

Save Caneel

And you can get precise colors:

? X

Red: 91
El New
Green: 155 E
Blue: 213 E
Current
4

Create New Theme Fonts ? X
Heading font: Sample

Heading

Body text body text body text. Body t¢

Calibri Light
Body font:
Calibri

L]l ]

Name: |Custom 1

Save | | Cancel
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